2026-01-22 Customers might notice Ingest lag and query latency

Incident Report for Observe

Resolved

The incident has been resolved - ingest and query latency health are back to normal.
Posted Jan 22, 2026 - 15:02 PST

Monitoring

The issue has been identified and a fix has been implemented. We will continue to monitor ingest lag and query latency in US West (Oregon)
Posted Jan 22, 2026 - 14:41 PST

Investigating

We’ve identified an issue causing ingest lag and query latency in the following regions: US West (Oregon). As a result, some users may experience delayed data processing in datasets resulting in dataset staleness. Our team is actively investigating the root cause and working to restore normal performance as quickly as possible. We’ll provide updates as we learn more. Thank you for your patience!
Posted Jan 22, 2026 - 12:16 PST