Dataset freshness is recovering, with most datasets now at nominal levels. Monitoring will continue until all datasets have been fully restored.
Posted Aug 21, 2025 - 07:41 PDT
Identified
We have identified the issue and are monitoring the recovery of datasets that are not meeting their freshness goals. We will continue to provide updates as we have them for the recovery progress.
Posted Aug 21, 2025 - 07:04 PDT
Update
We are continuing to investigate this issue.
Posted Aug 21, 2025 - 06:25 PDT
Investigating
We’ve identified an issue causing significant dataset staleness in the following regions: US West (Oregon) Limited Customers. As a result, some users may experience dataset staleness up to 12 hours. Currently there is no risk of data loss. Our team is actively investigating the root cause and working to restore normal performance as quickly as possible. We’ll provide updates as we learn more. Thank you for your patience!