2025-03-19 Delays in Monitors and Freshness

Incident Report for Observe

Resolved

This incident has been resolved
Posted Mar 19, 2025 - 21:19 PDT

Monitoring

We have applied a fix and are monitoring the recovery.
Posted Mar 19, 2025 - 18:35 PDT

Investigating

We have identified an issue causing Transform Latency affecting the following regions: GCP. As a result, some users may experience trouble running queries, delays in monitors, and delays in data freshness. Our team is actively investigating the root cause and working to restore normal performance as quickly as possible. We'll provide updates as we learn more. Thank you for your patience!
Posted Mar 19, 2025 - 18:00 PDT