2026-03-04: Delayed Monitor Alerts

Incident Report for Observe

Resolved

The incident has been resolved, and alerts performance has returned to expected levels.
Posted Mar 06, 2026 - 13:04 PST

Update

We are continuing to monitor the results. Some alerts may still trigger later than expected and appear outdated.
Posted Mar 05, 2026 - 09:47 PST

Monitoring

We have implemented a fix and and are currently monitoring the results. Some alerts may still trigger later than expected and appear outdated.
Posted Mar 04, 2026 - 18:39 PST

Investigating

We are currently investigating an issue causing delays in monitor alerts. As a result, some alerts may trigger later than expected and appear outdated.

Our team is actively working to identify the root cause and implement a fix. We will provide updates as soon as more information becomes available.
Posted Mar 04, 2026 - 14:58 PST