2026-09-04 Performance degradation in EU

Incident Report for Observe

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 02:24 PDT

Monitoring

A fix has been implemented and we are monitoring the results. Data freshness may require additional time to process and recover.
Posted Sep 04, 2026 - 01:45 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 04, 2026 - 01:37 PDT

Investigating

We are seeing a degradation of performance in some EU tenants. Users may experience longer page load times and longer query times. Data/ingest is not currently impacted.
Posted Sep 04, 2026 - 00:33 PDT