2026-06-03 Monitor V1 Alert Notification Pages Failing to Load (ALL)

Incident Report for Observe

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2026 - 21:34 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 03, 2026 - 13:38 PDT

Investigating

We are investigating an issue affecting Monitor V1 alert notification detail pages in all regions.

Customer impact: Clicking through to an alert detail page from a notification email or notification list causes the page to stall and not render. Monitor V1 evaluation, alert firing, and notification delivery are not affected.

Our team is actively working to identify the root cause. We will provide an update within 120 minutes.
Posted Jun 03, 2026 - 10:59 PDT